Cold Ride…

December 21, 2008 at 11:17 am 1 comment

So yesterday as I got off of work I was getting into my truck and getting it warmed up before I went home. I scraped the windows and climbed back in. I turned on my lights and put her into gear and then I turned the heater on. Only one problem….the heater didn’t come on. I tried multiple times to get it to work but nothing happened. It was fogging up in the cab quickly so I called my dad to see if he had any suggestions. He told me to roll down the windows so it didn’t fog up. I already had. It was a brisk 0 degrees outside. For those of you who can’t read numbers, that was zero degrees. So I headed home with both windows half down in zero degree weather. Wendy had suggested that morning that I bring a coat with me but I was content with my sweat shirt. What a fool I was. I didn’t have any gloves either, just my hoody. Well I was doing ok till I got out of the truck at home and realized I was uncontrollably shivering and my thumbs hurt like no other. It was the coldest I’ve been in quite some time. Hopefully it’s a simple heater fix…

Advertisements

Entry filed under: Nathan's Posts.

Breaking Dawn and moving on Even more stuck

1 Comment Add your own

  • 1. Mimi  |  December 21, 2008 at 10:18 pm

    Haha Nathan, but did you have back spasms you shivered so hard? It is so cold!

    Reply

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Trackback this post  |  Subscribe to the comments via RSS Feed


Calendar

December 2008
M T W T F S S
« Nov   Jan »
1234567
891011121314
15161718192021
22232425262728
293031  

Most Recent Posts


%d bloggers like this: